PHP Version auswählen

Standard Version von php mittel update-alternatives auswählen

PHP Version auswählen

Hat man mehrere PHP Versionen installiert (z.B. 7.4 und 8.0) kann es sein, dass man nicht immer die aktuellste Version via /usr/bin/php aufrufen möchte. Diese symbolische Verknüpfung kann man sehr gut mit update-alternatives verstellen.

php_version
So könnte es z.B. aussehen, wenn man v8 schon installiert hat aber noch v7.4 nutzen muss/möchte

Standard Version auf 7.4 umstellen

# Umstellung über interaktive auswahl
sudo update-alternatives --config php

php_auswahl

# Version direkt umstellen
sudo update-alternatives --set php /usr/bin/php7.4

Eine ausführliche Beschreibung gibt es hier: https://cloudwafer.com/blog/installing-multiple-versions-of-php-on-debian/